summaryrefslogtreecommitdiffstats
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
authorUlf Möller <ulf@openssl.org>1999-07-22 16:10:31 +0000
committerUlf Möller <ulf@openssl.org>1999-07-22 16:10:31 +0000
commit49b8142262247dcf6e0308e26cdb2d7f1bbafcb8 (patch)
tree8144e1c2ba653eecc652b94776783c6ee59db756 /perl/Makefile.PL
parentf0e8ae723cf8f86a91bdc5be8a6a5b956309729f (diff)
Make the perl module compile and eliminate some of the warnings.
Still doesn't work (the destructor on BIO and SSL is called immediately after creating the object. Why that??)
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL7
1 files changed, 5 insertions, 2 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index 09eb93653b..2a67ad061d 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -2,7 +2,11 @@
## Makefile.PL -- Perl MakeMaker specification
##
-$V = '0.9.2b';
+open(IN,"<../Makefile.ssl") || die "unable to open Makefile.ssl!\n";
+while(<IN>) {
+ $V=$1 if (/^VERSION=(.*)$/);
+}
+close(IN);
print "Configuring companion Perl module for OpenSSL $V\n";
use ExtUtils::MakeMaker;
@@ -18,7 +22,6 @@ WriteMakefile(
'DEFINE' => '',
'INC' => '-I../include',
'H' => ['openssl.h'],
- 'C' => ['openssl_cb.c'],
'OBJECT' =>
'OpenSSL.o ' .
'openssl_bio.o ' .