summaryrefslogtreecommitdiffstats
path: root/contrib/suse/openssh.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/suse/openssh.spec')
-rw-r--r--contrib/suse/openssh.spec4
1 files changed, 4 insertions, 0 deletions
diff --git a/contrib/suse/openssh.spec b/contrib/suse/openssh.spec
index 7d5d087a..0f63ef65 100644
--- a/contrib/suse/openssh.spec
+++ b/contrib/suse/openssh.spec
@@ -197,6 +197,10 @@ if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
echo "Generating SSH host key..."
/usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
fi
+if [ ! -f /etc/ssh/ssh_host_dsa_key -o ! -s /etc/ssh/ssh_host_dsa_key ]; then
+ echo "Generating SSH DSA host key..."
+ /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N '' >&2
+fi
if test -r /var/run/sshd.pid
then
echo "Restarting the running SSH daemon..."