summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c1bcb342..4dd08c71 100644
--- a/configure.in
+++ b/configure.in
@@ -150,6 +150,20 @@ case "$host" in
LIBS="$LIBS -lgen -lsocket"
no_dev_ptmx=1
;;
+*-dec-osf*)
+# This is untested
+ if test ! -z "USE_SIA" ; then
+ AC_MSG_CHECKING(for Digital Unix Security Integration Architecture)
+ if test -f /etc/sia/matrix.conf; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_OSF_SIA)
+ AC_DEFINE(DISABLE_LOGIN)
+ LIBS="$LIBS -lsecurity -ldb -lm -laud"
+ else
+ AC_MSG_RESULT(no)
+ fi
+ fi
+ ;;
esac
# Allow user to specify flags