summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index 3c26e3d7..b676193d 100644
--- a/configure.in
+++ b/configure.in
@@ -213,27 +213,6 @@ for ssldir in "" $tryssldir /usr/local/openssl /usr/lib/openssl /usr/local/ssl /
break;
], []
)
- AC_TRY_RUN(
- [
- #include <ssl/rsa.h>
- #include <ssl/bn.h>
- #include <ssl/sha.h>
- int main(void)
- {
- RSA *key; char a[2048],b[2048];;
- memset(a, 0, sizeof(a));memset(b, 0, sizeof(b));
- RAND_seed(a, sizeof(a));
- key=RSA_generate_key(32,3,NULL,NULL);
- if (key==NULL) return(1);
- return(-1==RSA_private_decrypt(RSA_size(key),a,b,key,RSA_NO_PADDING));
- }
- ],
- [
- AC_DEFINE(HAVE_SSL)
- found_crypto=1
- break;
- ], []
- )
done
if test ! -z "$found_crypto" ; then