summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-11-25 13:19:55 +1100
committerDamien Miller <djm@mindrot.org>1999-11-25 13:19:55 +1100
commit98ac007ad9e4b94c58e49b5ca86e9f444be930bd (patch)
treee66139db7d48bd90aa0b61b672a84a6d180acbf0 /configure.in
parent063fdf82755e53b5a2cf5265aaa654969b23b459 (diff)
Removed old with-askpass option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in47
1 files changed, 12 insertions, 35 deletions
diff --git a/configure.in b/configure.in
index b0dde23e..037478a6 100644
--- a/configure.in
+++ b/configure.in
@@ -137,46 +137,23 @@ AC_TRY_COMPILE(
]
)
-dnl Check whether use wants to disable the external ssh-askpass
-INSTALL_ASKPASS="yes"
-AC_MSG_CHECKING([whether to enable external ssh-askpass support])
-AC_ARG_WITH(askpass,
- [ --with-askpass=yes/no Enable external ssh-askpass support (default=yes)],
+AC_MSG_CHECKING([whether to build GNOME ssh-askpass])
+dnl Check whether user wants GNOME ssh-askpass
+AC_ARG_WITH(gnome-askpass,
+ [ --with-gnome-askpass Build the GNOME passphrase requester (default=no)],
[
if test x$withval = xno ; then
- INSTALL_ASKPASS="no"
+ GNOME_ASKPASS="";
else
- INSTALL_ASKPASS="yes"
+ GNOME_ASKPASS="gnome-ssh-askpass";
fi
- ]
-)
-if test "x$INSTALL_ASKPASS" = "xyes" ; then
- AC_DEFINE(USE_EXTERNAL_ASKPASS)
- AC_SUBST(INSTALL_ASKPASS)
- AC_MSG_RESULT(yes)
-else
- AC_MSG_RESULT(no)
-fi
-
-if test "x$INSTALL_ASKPASS" = "xyes" ; then
- AC_MSG_CHECKING([whether to build GNOME ssh-askpass])
- dnl Check whether user wants GNOME ssh-askpass
- AC_ARG_WITH(gnome-askpass,
- [ --with-gnome-askpass Build the GNOME passphrase requester (default=no)],
- [
- if test x$withval = xno ; then
- GNOME_ASKPASS="";
- else
- GNOME_ASKPASS="gnome-ssh-askpass";
- fi
- ])
- AC_SUBST(GNOME_ASKPASS)
+ ])
+AC_SUBST(GNOME_ASKPASS)
- if test -z "$GNOME_ASKPASS" ; then
- AC_MSG_RESULT(no)
- else
- AC_MSG_RESULT(yes)
- fi
+if test -z "$GNOME_ASKPASS" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
fi
dnl Check for user-specified random device