summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-11-19 13:03:25 +1100
committerDamien Miller <djm@mindrot.org>1999-11-19 13:03:25 +1100
commit8029775b77e8f8bc380518f9f734a9d979025bbb (patch)
tree3905893864df5ce304b30164378fcad91c10bcb0 /configure.in
parent18ac1719687a6671242d6a001cab01d55036ef8b (diff)
- Added autoconf option to enable Kerberos 4 support (untested)
- Added autoconf option to enable AFS support (untested) - Added autoconf option to enable S/Key support (untested) - Added autoconf option to enable TCP wrappers support (compiles OK)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 05a354d1..0b54fd58 100644
--- a/configure.in
+++ b/configure.in
@@ -166,4 +166,41 @@ AC_TRY_LINK([],
]
)
+dnl Check whether user wants Kerberos support
+AC_ARG_WITH(kerberos4,
+ [ --with-kerberos4 Enable Kerberos 4 support],
+ [
+ AC_DEFINE(KRB4)
+ LIBS="$LIBS -lkrb"
+ CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
+ ]
+)
+
+dnl Check whether user wants AFS support
+AC_ARG_WITH(kerberos4,
+ [ --with-afs Enable AFS support],
+ [
+ AC_DEFINE(AFS)
+ LIBS="$LIBS -lkafs"
+ ]
+)
+
+dnl Check whether user wants S/Key support
+AC_ARG_WITH(skey,
+ [ --with-skey Enable S/Key support],
+ [
+ AC_DEFINE(SKEY)
+ LIBS="$LIBS -lskey"
+ ]
+)
+
+dnl Check whether user wants TCP wrappers support
+AC_ARG_WITH(skey,
+ [ --with-tcp-wrappers Enable tcpwrappers support],
+ [
+ AC_DEFINE(LIBWRAP)
+ LIBS="$LIBS -lwrap"
+ ]
+)
+
AC_OUTPUT(Makefile)