summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2001-01-31 09:57:55 +1100
committerDamien Miller <djm@mindrot.org>2001-01-31 09:57:55 +1100
commit709528ab6a271ce39155fc494d40689f578f9d38 (patch)
tree5574e0b05aac9d0fa7e1ffd33f0342a5fc679c37 /configure.in
parent3c4659cb6ffb68ef0e81813eb737a3a3544e726c (diff)
- (djm) Fix autoconf logic for --with-lastlog=no Report and diagnosis from
Philipp Buehler <lists@fips.de> and Kevin Steves <stevesk@sweden.hp.com> respectively.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3a812d05..d9f59a31 100644
--- a/configure.in
+++ b/configure.in
@@ -1438,7 +1438,14 @@ AC_ARG_ENABLE(pututxline,
)
AC_ARG_WITH(lastlog,
[ --with-lastlog=FILE|DIR specify lastlog location [common locations]],
- [ conf_lastlog_location="$withval"; ],)
+ [
+ if test "x$withval" = "xno" ; then
+ AC_DEFINE(DISABLE_LASTLOG)
+ else
+ conf_lastlog_location=$withval
+ fi
+ ]
+)
dnl lastlog, [uw]tmpx? detection
dnl NOTE: set the paths in the platform section to avoid the