summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBen Lindstrom <mouring@eviladmin.org>2001-03-17 01:15:38 +0000
committerBen Lindstrom <mouring@eviladmin.org>2001-03-17 01:15:38 +0000
commit45b14dbddc244bba8c17d71186c2bc49b355636a (patch)
tree379b4872dcd775fc18feff237342aa331d63031a /configure.in
parent7bb8b49596156b85df403d09c2195e2533ec372c (diff)
- Check for gl_matchc support in glob_t and fall back to the
openbsd-compat/glob.[ch] support if it does not exist.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d3a902a8..a6ad607c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.265 2001/03/14 00:39:46 djm Exp $
+# $Id: configure.in,v 1.266 2001/03/17 01:15:38 mouring Exp $
AC_INIT(ssh.c)
@@ -388,6 +388,24 @@ AC_EGREP_CPP(FOUNDIT,
]
)
+# Check for g.gl_matchc glob() extension
+AC_MSG_CHECKING(for gl_matchc field in glob_t)
+AC_EGREP_CPP(FOUNDIT,
+ [
+ #include <glob.h>
+ int main(void){glob_t g; g.gl_matchc = 1;}
+ ],
+ [
+ AC_DEFINE(GLOB_HAS_GL_MATCHC)
+ AC_MSG_RESULT(yes)
+ ],
+ [
+ AC_MSG_RESULT(no)
+ ]
+)
+
+
+
# Check whether user wants Kerberos support
KRB4_MSG="no"
AC_ARG_WITH(kerberos4,