summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2001-02-28 12:49:38 +1100
committerDamien Miller <djm@mindrot.org>2001-02-28 12:49:38 +1100
commit3d8ae61b878bc49807307a29b6f30c90636d3980 (patch)
treeebc54316d1528cb52fc5529500656ec5a2a2ba05 /configure.in
parentefb71798150bb9faaf739e0e604a21db6c31e0cf (diff)
- (djm) EGD detection patch from Tim Rice <tim@multitalents.net>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b1eb4d4d..e6111684 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.257 2001/02/27 21:14:22 djm Exp $
+# $Id: configure.in,v 1.258 2001/02/28 01:49:38 djm Exp $
AC_INIT(ssh.c)
@@ -1280,14 +1280,14 @@ AC_ARG_WITH(egd-pool,
if test -z "$RANDOM_POOL" ; then
AC_MSG_CHECKING(for PRNGD/EGD socket)
# Insert other locations here
- for egdsock in /var/run/egd-pool /etc/entropy /tmp/entropy ; do
+ for egdsock in /var/run/egd-pool /tmp/egd-pool /etc/entropy /tmp/entropy ; do
if test -r $egdsock && $TEST_MINUS_S_SH -c "test -S $egdsock -o -p $egdsock" ; then
EGD_SOCKET="$egdsock"
AC_DEFINE_UNQUOTED(EGD_SOCKET, "$EGD_SOCKET")
break;
fi
done
- if test -x "$EGD_SOCKET" ; then
+ if test ! -z "$EGD_SOCKET" ; then
AC_MSG_RESULT($EGD_SOCKET)
else
AC_MSG_RESULT(not found)