summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-04-30 09:30:44 +1000
committerDamien Miller <djm@mindrot.org>2000-04-30 09:30:44 +1000
commit4018c1985d6e34f4625132965e814880ac3075ba (patch)
tree1a3450e78dc2fa600f485a07a5c5a866781f082c /configure.in
parent1bead335d7381b553bc4a13b3ea2b9dc09679123 (diff)
- Integrate Andre Lucas' <andre.lucas@dial.pipex.com> entropy collection
patch. - Adds timeout to entropy collection - Disables slow entropy sources - Load and save seed file - Changed entropy seed code to user per-user seeds only (server seed is saved in root's .ssh directory) - Use atexit() and fatal cleanups to save seed on exit
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fbf117b9..c533d420 100644
--- a/configure.in
+++ b/configure.in
@@ -43,6 +43,7 @@ case "$host" in
LDFLAGS="$LDFLAGS -L/usr/local/lib"
AC_DEFINE(IPADDR_IN_DISPLAY)
AC_DEFINE(USE_UTMPX)
+ AC_DEFINE(NEED_IN_SYSTM_H)
AC_MSG_CHECKING(for HPUX trusted system password database)
if test -f /tcb/files/auth/system/default; then
AC_MSG_RESULT(yes)
@@ -907,9 +908,24 @@ AC_ARG_WITH(pid-dir,
fi
]
)
+
AC_DEFINE_UNQUOTED(PIDDIR, "$piddir")
AC_SUBST(piddir)
+
+# Change default command timeout for builtin PRNG
+entropy_timeout=100
+AC_ARG_WITH(entropy-timeout,
+ [ --with-entropy-timeout Specify entropy gathering command timeout (msec)],
+ [
+ if test "x$withval" != "xno" ; then
+ entropy_timeout=$withval
+ fi
+ ]
+)
+AC_DEFINE_UNQUOTED(ENTROPY_TIMEOUT_MSEC, $entropy_timeout)
+
+
if test ! -z "$blibpath" ; then
LDFLAGS="$LDFLAGS -blibpath:$blibpath"
AC_MSG_WARN([Please check and edit -blibpath in LDFLAGS in Makefile])