summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBen Lindstrom <mouring@eviladmin.org>2000-11-10 02:41:30 +0000
committerBen Lindstrom <mouring@eviladmin.org>2000-11-10 02:41:30 +0000
commit305fb0018a1485a040eac264527b3fd4557a461a (patch)
tree731fd59b242eddc0560c712cb8c7652e0301f3d4 /configure.in
parentdbcea870630e6e6cedc6937d33da4e2e4c6d5390 (diff)
- (bal) Fixed dropped answer from skey_keyinfo() in auth1.c - (bal) Changed from --with-skey to --with-skey=PATH in configure.in - (bal) Added in check to verify S/Key library is being detected in configure.in - (bal) next-posix.h - added another prototype wrapped in POSIX ifdef/endif. Patch by Mark Miller <markm@swoon.net> - (bal) Added 'util.h' header to loginrec.c only if HAVE_UTIL_H is defined to remove warnings under MacOS X. Patch by Mark Miller <markm@swoon.net> - (bal) Fixed LDFLAG mispelling in configure.in for --with-afs
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0c43efcb..be500da2 100644
--- a/configure.in
+++ b/configure.in
@@ -1085,7 +1085,7 @@ AC_ARG_WITH(afs,
if test "x$withval" != "xyes" ; then
CFLAGS="$CFLAGS -I${withval}/include"
- LFLAGS="$LFLAGS -L${withval}/lib"
+ LDFLAGS="$LDFLAGS -L${withval}/lib"
fi
if test -z "$KRB4" ; then
@@ -1106,12 +1106,24 @@ LIBS="$LIBS $KLIBS"
# Check whether user wants S/Key support
SKEY_MSG="no"
AC_ARG_WITH(skey,
- [ --with-skey Enable S/Key support],
+ [ --with-skey=PATH Enable S/Key support],
[
if test "x$withval" != "xno" ; then
+
+ if test "x$withval" != "xyes" ; then
+ CFLAGS="$CFLAGS -I${withval}/include"
+ LDFLAGS="$LDFLAGS -L${withval}/lib"
+ fi
+
AC_DEFINE(SKEY)
LIBS="$LIBS -lskey"
SKEY_MSG="yes"
+
+ AC_CHECK_FUNC(skey_keyinfo,
+ [],
+ [
+ AC_MSG_ERROR([** Incomplete or missing s/key libraries.])
+ ])
fi
]
)