summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-06-20 13:25:52 +1000
committerDamien Miller <djm@mindrot.org>2000-06-20 13:25:52 +1000
commitedb82929fa3d9158a818249881083d65b305cb78 (patch)
treedeaa6dcdda1f290fcf89439edc78cf48b6a89327 /configure.in
parent98cabe05469dd5ed132b47d95177867c70992c8b (diff)
- (djm) Replace use of '-o' and '-a' logical operators in configure tests
with '||' and '&&'. As suggested by Jim Knoble <jmknoble@pint-stowp.cx> to fix SCO Unixware problem reported by Gary E. Miller <gem@rellim.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index d574cfc5..2ae0d21c 100644
--- a/configure.in
+++ b/configure.in
@@ -31,7 +31,7 @@ case "$host" in
AFS_LIBS="-lld"
CFLAGS="$CFLAGS -I/usr/local/include"
LDFLAGS="$LDFLAGS -L/usr/local/lib"
- if test "$LD" != "gcc" -a -z "$blibpath"; then
+ if (test "$LD" != "gcc" && test -z "$blibpath"); then
blibpath="/usr/lib:/lib:/usr/local/lib"
fi
AC_CHECK_FUNC(authenticate, [AC_DEFINE(WITH_AIXAUTHENTICATE)])
@@ -230,7 +230,7 @@ AC_ARG_WITH(pam,
fi
]
)
-if test -z "$no_pam" -a "x$ac_cv_header_security_pam_appl_h" = "xyes" ; then
+if (test -z "$no_pam" && test "x$ac_cv_header_security_pam_appl_h" = "xyes") ; then
AC_CHECK_LIB(dl, dlopen, , )
LIBS="$LIBS -lpam"
@@ -321,7 +321,7 @@ int main(void)
ac_cv_openssldir=$ssldir
])
-if test ! -z "$ac_cv_openssldir" -a ! "x$ac_cv_openssldir" = "x(system)" ; then
+if (test ! -z "$ac_cv_openssldir" && test "x$ac_cv_openssldir" != "x(system)") ; then
AC_DEFINE(HAVE_OPENSSL)
dnl Need to recover ssldir - test above runs in subshell
ssldir=$ac_cv_openssldir
@@ -421,8 +421,8 @@ if test "x$ac_cv_have_u_intxx_t" = "xyes" ; then
fi
-if test -z "$have_u_intxx_t" -o -z "$have_intxx_t" -a \
- "x$ac_cv_header_sys_bitypes_h" = "xyes"
+if (test -z "$have_u_intxx_t" || test -z "$have_intxx_t" && \
+ test "x$ac_cv_header_sys_bitypes_h" = "xyes")
then
AC_MSG_CHECKING([for intXX_t and u_intXX_t types in sys/bitypes.h])
AC_TRY_COMPILE(
@@ -679,7 +679,7 @@ AC_ARG_WITH(xauth,
],
[
AC_PATH_PROG(xauth_path, xauth)
- if test ! -z "$xauth_path" -a -x "/usr/openwin/bin/xauth" ; then
+ if (test ! -z "$xauth_path" && test -x "/usr/openwin/bin/xauth") ; then
xauth_path="/usr/openwin/bin/xauth"
fi
]
@@ -750,7 +750,7 @@ AC_ARG_WITH(egd-pool,
# detect pathnames for entropy gathering commands, if we need them
INSTALL_SSH_PRNG_CMDS=""
rm -f prng_commands
-if test -z "$RANDOM_POOL" -a -z "$EGD_SOCKET" ; then
+if (test -z "$RANDOM_POOL" && test -z "$EGD_SOCKET") ; then
# Use these commands to collect entropy
OSSH_PATH_ENTROPY_PROG(PROG_LS, ls)
OSSH_PATH_ENTROPY_PROG(PROG_NETSTAT, netstat)
@@ -1077,7 +1077,7 @@ AC_TRY_COMPILE([
if test -z "$conf_lastlog_location"; then
if test x"$system_lastlog_path" = x"no" ; then
for f in /var/log/lastlog /usr/adm/lastlog /var/adm/lastlog /etc/security/lastlog ; do
- if test -d "$f" -o -f "$f" ; then
+ if (test -d "$f" || test -f "$f") ; then
conf_lastlog_location=$f
fi
done