summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-06-23 08:23:34 +1000
committerDamien Miller <djm@mindrot.org>2000-06-23 08:23:34 +1000
commitb54b40ef06517dc3091253228f06d3bd54f19a82 (patch)
treead094e0baa6a0af32ee0ceda85369d464e35b85c /configure.in
parentc19fd5f4e25f58af35cbede8a442ed3965e32eb0 (diff)
- (djm) Use sa_family_t in prototype for rresvport_af. Patch from
Svante Signell <svante.signell@telia.com> - (djm) Autoconf logic to define sa_family_t if it is missing
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2ae0d21c..d9a87d8e 100644
--- a/configure.in
+++ b/configure.in
@@ -502,6 +502,21 @@ if test "x$ac_cv_have_ssize_t" = "xyes" ; then
AC_DEFINE(HAVE_SSIZE_T)
fi
+AC_CACHE_CHECK([for sa_family_t], ac_cv_have_sa_family_t, [
+ AC_TRY_COMPILE(
+ [
+#include <sys/types.h>
+#include <sys/socket.h>
+ ],
+ [ sa_family_t foo; foo = 1235; ],
+ [ ac_cv_have_sa_family_t="yes" ],
+ [ ac_cv_have_sa_family_t="no" ]
+ )
+])
+if test "x$ac_cv_have_sa_family_t" = "xyes" ; then
+ AC_DEFINE(HAVE_SA_FAMILY_T)
+fi
+
AC_CACHE_CHECK([for pid_t], ac_cv_have_pid_t, [
AC_TRY_COMPILE(
[