summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-08-30 10:03:33 +1100
committerDamien Miller <djm@mindrot.org>2000-08-30 10:03:33 +1100
commit9a94734d25ff8a632fd1dd3114d64e79a99474ba (patch)
treed2610f165ee244c30b68870831120fb77d832974 /configure.in
parent7cfaaf234f5fad764962462508293a81dc577782 (diff)
- (djm) Fix printing of $DISPLAY hack if set by system type. Report from
Kevin Steves <stevesk@sweden.hp.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 17 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 4e5567a9..5321aedc 100644
--- a/configure.in
+++ b/configure.in
@@ -59,7 +59,7 @@ case "$host" in
CFLAGS="$CFLAGS -Ae"
fi
CFLAGS="$CFLAGS -D_HPUX_SOURCE"
- AC_DEFINE(IPADDR_IN_DISPLAY)
+ IPADDR_IN_DISPLAY=yes
AC_DEFINE(USE_PIPES)
AC_MSG_CHECKING(for HPUX trusted system password database)
if test -f /tcb/files/auth/system/default; then
@@ -76,7 +76,7 @@ case "$host" in
;;
*-*-hpux11*)
CFLAGS="$CFLAGS -D_HPUX_SOURCE"
- AC_DEFINE(IPADDR_IN_DISPLAY)
+ IPADDR_IN_DISPLAY=yes
AC_DEFINE(USE_PIPES)
AC_MSG_CHECKING(for HPUX trusted system password database)
if test -f /tcb/files/auth/system/default; then
@@ -1094,16 +1094,21 @@ if test -z "$disable_shadow" ; then
fi
# Use ip address instead of hostname in $DISPLAY
-DISPLAY_HACK_MSG="no"
-AC_ARG_WITH(ipaddr-display,
- [ --with-ipaddr-display Use ip address instead of hostname in \$DISPLAY],
- [
- if test "x$withval" != "xno" ; then
- AC_DEFINE(IPADDR_IN_DISPLAY)
- DISPLAY_HACK_MSG="yes"
- fi
- ]
-)
+if test ! -z "$IPADDR_IN_DISPLAY" ; then
+ DISPLAY_HACK_MSG="yes"
+ AC_DEFINE(IPADDR_IN_DISPLAY)
+else
+ DISPLAY_HACK_MSG="no"
+ AC_ARG_WITH(ipaddr-display,
+ [ --with-ipaddr-display Use ip address instead of hostname in \$DISPLAY],
+ [
+ if test "x$withval" != "xno" ; then
+ AC_DEFINE(IPADDR_IN_DISPLAY)
+ DISPLAY_HACK_MSG="yes"
+ fi
+ ]
+ )
+fi
# Whether to mess with the default path
SERVER_PATH_MSG="(default)"