summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-10-25 10:06:04 +1100
committerDamien Miller <djm@mindrot.org>2000-10-25 10:06:04 +1100
commit6f9c337401d455b92d85913432f0fc1129812b1f (patch)
tree891a5a416ee5d9826245701578f79d5bb20dfc81 /configure.in
parente5a8525242deb13d5263d2da46365053f05262d4 (diff)
- (djm) Added WARNING.RNG file and modified configure to ask users of the
builtin entropy code to read it. - (djm) Prefer builtin regex to PCRE.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ed4d0519..90e75bef 100644
--- a/configure.in
+++ b/configure.in
@@ -266,8 +266,14 @@ AC_ARG_WITH(libs,
# Checks for libraries.
AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first ***]))
AC_CHECK_LIB(util, login, AC_DEFINE(HAVE_LIBUTIL_LOGIN) LIBS="$LIBS -lutil")
-AC_CHECK_LIB(pcre, pcre_info,
- AC_DEFINE(HAVE_LIBPCRE) LIBS="$LIBS -lpcreposix -lpcre")
+
+AC_CHECK_FUNC(regcomp,
+ [],
+ [
+ AC_CHECK_LIB(pcre, pcre_info,
+ AC_DEFINE(HAVE_LIBPCRE) LIBS="$LIBS -lpcreposix -lpcre")
+ ]
+)
if test -z "$no_libsocket" ; then
AC_CHECK_LIB(nsl, yp_match, , )
@@ -1531,6 +1537,7 @@ else
RAND_MSG="EGD ($EGD_SOCKET)"
else
RAND_MSG="Builtin (timeout $entropy_timeout)"
+ BUILTIN_RNG=1
fi
fi
@@ -1574,3 +1581,9 @@ echo " Libraries: ${LIBS}"
echo ""
+if test ! -z "$BUILTIN_RNG" ; then
+ echo "WARNING: you are using the builtin random number collection service."
+ echo "Please read WARNING.RNG and request that your OS vendor includes"
+ echo "/dev/random in future versions of their OS."
+ echo ""
+fi