summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-06-26 11:31:33 +1000
committerDamien Miller <djm@mindrot.org>2000-06-26 11:31:33 +1000
commit1f335fb8d81a23c6ddce3062a4e2d4efe9d8a59e (patch)
treee0b2ff2cff12a83740f16bb7da48f592402bdcae /configure.in
parentc0fd17fdca5853c0c6bfdfc364d8c5418dcab86b (diff)
- (djm) Account expiry support from Andreas Steinmetz <ast@domdv.de>
- (djm) Added password expiry checking (no password change support)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d9a87d8e..ca433e56 100644
--- a/configure.in
+++ b/configure.in
@@ -236,6 +236,8 @@ if (test -z "$no_pam" && test "x$ac_cv_header_security_pam_appl_h" = "xyes") ; t
AC_CHECK_FUNCS(pam_getenvlist)
+ disable_shadow=yes
+
PAM_MSG="yes"
# Check PAM strerror arguments (old PAM)
@@ -933,10 +935,30 @@ AC_ARG_WITH(shadow,
[
if test "x$withval" = "xno" ; then
AC_DEFINE(DISABLE_SHADOW)
+ disable_shadow=yes
fi
]
)
+if test -z "$disable_shadow" ; then
+ AC_MSG_CHECKING([if the systems has expire shadow information])
+ AC_TRY_COMPILE(
+ [
+#include <sys/types.h>
+#include <shadow.h>
+ struct spwd sp;
+ ],[ sp.sp_expire = sp.sp_lstchg = sp.sp_inact = 0; ],
+ [ sp_expire_available=yes ], []
+ )
+
+ if test "x$sp_expire_available" = "xyes" ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAS_SHADOW_EXPIRE)
+ else
+ AC_MSG_RESULT(no)
+ fi
+fi
+
# Use ip address instead of hostname in $DISPLAY
DISPLAY_HACK_MSG="no"
AC_ARG_WITH(ipaddr-display,