summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2001-08-07 15:29:07 -0700
committerTim Rice <tim@multitalents.net>2001-08-07 15:29:07 -0700
commite991e3cf221c9f898b7ec0c5e7492bb1202cefc4 (patch)
treebe55c57e75269fb299f9cbcf32a5c0ab58cfd2b4 /configure.in
parent6db66ff3877f52110cda3104e798d91091af7200 (diff)
- (tim) [configure.in sshconnect.c openbsd-compat/Makefile.in
openbsd-compat/openbsd-compat.h ] Add inet_ntop.c inet_ntop.h back in. Needed for sshconnect.c [sshconnect.c] fix INET6_ADDRSTRLEN for non IPv6 machines [configure.in] make tests with missing libraries fail patch by Wendy Palm <wendyp@cray.com> Added openbsd-compat/bsd-cray.h. Selective patches from William L. Jones <jones@mail.utexas.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 4210d3e9..28843226 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.305 2001/08/06 23:29:17 mouring Exp $
+# $Id: configure.in,v 1.306 2001/08/07 22:29:08 tim Exp $
AC_INIT(ssh.c)
@@ -242,12 +242,12 @@ mips-sony-bsd|mips-sony-newsos4)
MANTYPE=man
;;
*-*-unicos*)
- no_libsocket=1
- no_libnsl=1
+ no_libsocket=1
+ no_libnsl=1
AC_DEFINE(USE_PIPES)
- LDFLAGS="$LDFLAGS -L/usr/local/lib"
- LIBS="$LIBS -lgen -lrsc"
- ;;
+ LDFLAGS="$LDFLAGS -Wl,-Dmsglevel=334:fatal,-L/usr/local/lib"
+ LIBS="$LIBS -lgen -lrsc"
+ ;;
*-dec-osf*)
AC_MSG_CHECKING(for Digital Unix SIA)
no_osfsia=""
@@ -469,7 +469,7 @@ AC_ARG_WITH(tcp-wrappers,
)
dnl Checks for library functions.
-AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_sa clock dirname fchown fchmod freeaddrinfo futimes gai_strerror getcwd getaddrinfo getgrouplist getopt getnameinfo getrlimit getrusage getttyent glob inet_aton inet_ntoa innetgr login_getcapbool md5_crypt memmove mkdtemp on_exit openpty readpassphrase realpath rresvport_af setdtablesize setenv setegid seteuid setlogin setproctitle setresgid setreuid setrlimit setsid setvbuf sigaction sigvec snprintf strerror strlcat strlcpy strmode strsep sysconf tcgetpgrp utimes vsnprintf vhangup vis waitpid _getpty __b64_ntop)
+AC_CHECK_FUNCS(arc4random atexit b64_ntop bcopy bindresvport_sa clock dirname fchown fchmod freeaddrinfo futimes gai_strerror getcwd getaddrinfo getgrouplist getopt getnameinfo getrlimit getrusage getttyent glob inet_aton inet_ntoa inet_ntop innetgr login_getcapbool md5_crypt memmove mkdtemp on_exit openpty readpassphrase realpath rresvport_af setdtablesize setenv setegid seteuid setlogin setproctitle setresgid setreuid setrlimit setsid setvbuf sigaction sigvec snprintf strerror strlcat strlcpy strmode strsep sysconf tcgetpgrp utimes vsnprintf vhangup vis waitpid _getpty __b64_ntop)
dnl Checks for time functions
AC_CHECK_FUNCS(gettimeofday time)
dnl Checks for libutil functions