summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2001-06-27 23:35:51 +1000
committerDamien Miller <djm@mindrot.org>2001-06-27 23:35:51 +1000
commit649d999b4bab2d2ff5fadf7c77f2d685ece4708c (patch)
treeb1af765fe8fcbbc57f5b73798244cee091beb79b /configure.in
parentb90416b7df65a0d8e36c5e6887e33ebd8b25125c (diff)
- (djm) Turn up warnings if gcc or egcs detected
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 199c1a69..554d1cf4 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.292 2001/06/25 08:09:17 djm Exp $
+# $Id: configure.in,v 1.293 2001/06/27 13:35:53 djm Exp $
AC_INIT(ssh.c)
@@ -41,10 +41,9 @@ if test -z "$LD" ; then
fi
AC_SUBST(LD)
-# C Compiler features
AC_C_INLINE
-if test "$GCC" = "yes"; then
- CFLAGS="$CFLAGS -Wall"
+if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
+ CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wno-uninitialized"
fi
# Check for some target-specific stuff