summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2001-03-28 14:35:30 +1000
committerDamien Miller <djm@mindrot.org>2001-03-28 14:35:30 +1000
commit18bb473eb0509ef74cb7eb644925a9afaa8efaae (patch)
tree7f9ae81f1b275197e9f129910213fa2487d9593d /configure.in
parentc79bc0d75bca9367947020dd3ec806d33fa19b1b (diff)
- (djm) Work around Solaris' broken struct dirent. Diagnosis and suggested
fix from Philippe Levan <levan@epix.net>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 638877ed..f6a0a692 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.268 2001/03/28 03:03:42 djm Exp $
+# $Id: configure.in,v 1.269 2001/03/28 04:35:30 djm Exp $
AC_INIT(ssh.c)
@@ -404,6 +404,20 @@ AC_EGREP_CPP(FOUNDIT,
]
)
+AC_MSG_CHECKING([whether struct dirent allocates space for d_name])
+AC_TRY_RUN(
+ [
+#include <sys/types.h>
+#include <dirent.h>
+int main(void){struct dirent d;return(sizeof(d.d_name)<=sizeof(char));}
+ ],
+ [AC_MSG_RESULT(yes)],
+ [
+ AC_MSG_RESULT(no)
+ AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME)
+ ]
+)
+
# Check whether user wants S/Key support
SKEY_MSG="no"
AC_ARG_WITH(skey,