summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorKevin Steves <stevesk@pobox.com>2001-06-22 21:14:18 +0000
committerKevin Steves <stevesk@pobox.com>2001-06-22 21:14:18 +0000
commit824569537f874d754041f2c1b0898feda0c12f31 (patch)
tree4970f290470e0bf75a37133e35b82a9ff5dc9894 /configure.in
parent601e43638e9e7889127634c3ba0949ba9fb917aa (diff)
- (stevesk) handle systems without pw_expire and pw_change.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 30 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 104f7e57..69d15bb8 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.290 2001/06/10 17:24:52 mouring Exp $
+# $Id: configure.in,v 1.291 2001/06/22 21:14:19 stevesk Exp $
AC_INIT(ssh.c)
@@ -1144,6 +1144,35 @@ if test "x$ac_cv_have_pw_class_in_struct_passwd" = "xyes" ; then
AC_DEFINE(HAVE_PW_CLASS_IN_PASSWD)
fi
+AC_CACHE_CHECK([for pw_expire field in struct passwd],
+ ac_cv_have_pw_expire_in_struct_passwd, [
+ AC_TRY_COMPILE(
+ [
+#include <pwd.h>
+ ],
+ [ struct passwd p; p.pw_expire = 0; ],
+ [ ac_cv_have_pw_expire_in_struct_passwd="yes" ],
+ [ ac_cv_have_pw_expire_in_struct_passwd="no" ]
+ )
+])
+if test "x$ac_cv_have_pw_expire_in_struct_passwd" = "xyes" ; then
+ AC_DEFINE(HAVE_PW_EXPIRE_IN_PASSWD)
+fi
+
+AC_CACHE_CHECK([for pw_change field in struct passwd],
+ ac_cv_have_pw_change_in_struct_passwd, [
+ AC_TRY_COMPILE(
+ [
+#include <pwd.h>
+ ],
+ [ struct passwd p; p.pw_change = 0; ],
+ [ ac_cv_have_pw_change_in_struct_passwd="yes" ],
+ [ ac_cv_have_pw_change_in_struct_passwd="no" ]
+ )
+])
+if test "x$ac_cv_have_pw_change_in_struct_passwd" = "xyes" ; then
+ AC_DEFINE(HAVE_PW_CHANGE_IN_PASSWD)
+fi
AC_CACHE_CHECK([if libc defines __progname], ac_cv_libc_defines___progname, [
AC_TRY_LINK([],