summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-12-31 08:59:04 +1100
committerDamien Miller <djm@mindrot.org>1999-12-31 08:59:04 +1100
commitf3e8be87ebf4eb489bcf983cf60f5f55755a8740 (patch)
tree712ad39f34ec510e249d448a4f6e8f78b5d5aec9 /configure.in
parent8eb0fd6d6fee368ff0c3de479b0c18763fe3ea3a (diff)
- Fix broken autoconf typedef detection. Report from Marc G.
Fournier <marc.fournier@acadiau.ca>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 4e5bc602..dd3e1684 100644
--- a/configure.in
+++ b/configure.in
@@ -184,8 +184,10 @@ AC_TRY_COMPILE(
AC_MSG_CHECKING([For socklen_t])
AC_TRY_COMPILE(
- [#include <sys/types.h>],
- [#include <sys/socket.h>],
+ [
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ ],
[socklen_t foo; foo = 1235;],
[
AC_DEFINE(HAVE_SOCKLEN_T)
@@ -197,7 +199,6 @@ AC_TRY_COMPILE(
AC_MSG_CHECKING([For size_t])
AC_TRY_COMPILE(
[#include <sys/types.h>],
- [#include <sys/socket.h>],
[size_t foo; foo = 1235;],
[
AC_DEFINE(HAVE_SIZE_T)