summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-01-17 22:02:17 +1100
committerDamien Miller <djm@mindrot.org>2000-01-17 22:02:17 +1100
commitb13c73e385ec7f5fe9c81078c71e01141894eca6 (patch)
treef090e9cf59d5c95a844f9b5417c5cd85b1193e91 /configure.in
parent6640995be8a3fde9636c7a5aae539966eb989ee6 (diff)
- Substitute PID directory in sshd.8. Suggestion from Andrew
Stribblehill <a.d.stribblehill@durham.ac.uk>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e7524cd6..b356beb5 100644
--- a/configure.in
+++ b/configure.in
@@ -661,14 +661,17 @@ AC_ARG_WITH(default-path,
]
)
+piddir=/var/run
AC_ARG_WITH(pid-dir,
[ --with-pid-dir=PATH Specify location of ssh.pid file],
[
if test "x$withval" != "xno" ; then
- AC_DEFINE_UNQUOTED(PID_DIR, "$withval")
+ piddir=$withval
fi
]
)
+AC_DEFINE_UNQUOTED(PID_DIR, "$piddir")
+AC_SUBST(piddir)
dnl Check for mail directory (last resort if we cannot get it from headers)
if test ! -z "$MAIL" ; then