summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-12-29 02:32:22 +1100
committerDamien Miller <djm@mindrot.org>1999-12-29 02:32:22 +1100
commit9550a76c3716acc1a591dd9604cbc958a92ad891 (patch)
tree39968e63afca468fc699f9629a16868b015394a4 /configure.in
parent74d0d4a3d9157823fda11c892c6d592562486b84 (diff)
- Applied another NetBSD portability patch from David Rankin
<drankin@bohemians.lexington.ky.us> - Fix --with-default-path option.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a232a746..6d03beca 100644
--- a/configure.in
+++ b/configure.in
@@ -302,6 +302,11 @@ AC_EGREP_HEADER(ut_tv, utmp.h,
[AC_DEFINE(HAVE_TV_IN_UTMP) AC_MSG_RESULT(yes); ],
[AC_MSG_RESULT(no)]
)
+AC_MSG_CHECKING([whether utmp.h has ut_id field])
+AC_EGREP_HEADER(ut_id, utmp.h,
+ [AC_DEFINE(HAVE_ID_IN_UTMP) AC_MSG_RESULT(yes); ],
+ [AC_MSG_RESULT(no)]
+)
dnl Look for lastlog location
AC_ARG_WITH(lastlog,
@@ -440,7 +445,7 @@ AC_ARG_WITH(path,
[ --with-default-path=PATH Specify default \$PATH environment for server],
[
if test "x$withval" != "xno" ; then
- AC_DEFINE_UNQUOTED(USER_PATH, $withval")
+ AC_DEFINE_UNQUOTED(USER_PATH, "$withval")
fi
]
)