summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-01-19 14:36:49 +1100
committerDamien Miller <djm@mindrot.org>2000-01-19 14:36:49 +1100
commit7d80e3484b5a41249bee4d43b4c9a58d6ebe90a6 (patch)
tree80f2ae37acdadd0c5b409e63b454083e5367c6ab /configure.in
parenteaf9994f7e5fdddb7ded0cd9d757921ed8a9dc67 (diff)
- Linux/glibc-2.1.2 takes a *long* time to look up names for AF_UNSPEC
addresses using getaddrinfo(). Added a configure switch to make the default lookup mode AF_INET
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d11c519d..45df18f6 100644
--- a/configure.in
+++ b/configure.in
@@ -662,6 +662,15 @@ AC_ARG_WITH(default-path,
]
)
+AC_ARG_WITH(ipv4-default,
+ [ --with-ipv4-default Use IPv4 by connections unless '-6' specified],
+ [
+ if test "x$withval" != "xno" ; then
+ AC_DEFINE(IPV4_DEFAULT)
+ fi
+ ]
+)
+
piddir=/var/run
AC_ARG_WITH(pid-dir,
[ --with-pid-dir=PATH Specify location of ssh.pid file],