summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-03-11 20:45:40 +1100
committerDamien Miller <djm@mindrot.org>2000-03-11 20:45:40 +1100
commit7bcb089ef791e2b624cf349ba24bf798aebef99a (patch)
tree40be5ead7ace0d0e16adb69781f05483e58511ca /configure.in
parentd58b3abe0e9d887a00679245065ee91b8565037f (diff)
- IPv6 workarounds from Hideaki YOSHIFUJI <yoshfuji@ecei.tohoku.ac.jp>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 90aadd98..4f1e4796 100644
--- a/configure.in
+++ b/configure.in
@@ -55,6 +55,8 @@ case "$host" in
;;
*-*-linux*)
no_dev_ptmx=1
+ AC_DEFINE(DONT_TRY_OTHER_AF)
+ inet6_default_4in6=yes
;;
*-*-netbsd*)
need_dash_r=1
@@ -788,6 +790,26 @@ AC_ARG_WITH(ipv4-default,
]
)
+AC_MSG_CHECKING([to convert IPv4 in IPv6-mapped addresses])
+AC_ARG_WITH(4in6,
+ [ --with-4in6 Check for and convert IPv4 in IPv6 mapped addresses],
+ [
+ if test "x$withval" != "xno" ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(IPV4_IN_IPV6)
+ else
+ AC_MSG_RESULT(no)
+ fi
+ ],[
+ if test "x$inet6_default_4in6" = "xyes"; then
+ AC_MSG_RESULT([yes (default)])
+ AC_DEFINE(IPV4_IN_IPV6)
+ else
+ AC_MSG_RESULT([no (default)])
+ fi
+ ]
+)
+
# Where to place sshd.pid
piddir=/var/run
AC_ARG_WITH(pid-dir,