summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-12-29 02:24:35 +1100
committerDamien Miller <djm@mindrot.org>1999-12-29 02:24:35 +1100
commit74d0d4a3d9157823fda11c892c6d592562486b84 (patch)
tree05f34967c155b2dc0689ad6a0f76f1227f68ab89 /configure.in
parentcadc6bb72f60e48c65397eb67e76064931d78306 (diff)
- Merged AIX patch from Darren Hall <dhall@virage.org>
- Cleaned up defines.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 274111e2..a232a746 100644
--- a/configure.in
+++ b/configure.in
@@ -177,6 +177,18 @@ AC_TRY_COMPILE(
[AC_MSG_RESULT(no)]
)
+AC_MSG_CHECKING([For socklen_t])
+AC_TRY_COMPILE(
+ [#include <sys/types.h>],
+ [#include <sys/socket.h>],
+ [socklen_t foo; foo = 1235;],
+ [
+ AC_DEFINE(HAVE_SOCKLEN_T)
+ AC_MSG_RESULT(yes)
+ ],
+ [AC_MSG_RESULT(no)]
+)
+
AC_ARG_WITH(pam,
[ --without-pam Disable PAM support ],
[