summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-12-27 09:48:56 +1100
committerDamien Miller <djm@mindrot.org>1999-12-27 09:48:56 +1100
commit5a3e68382d3414b922af58a19196635d750581ca (patch)
tree2793f24954e3f857d010ce4d8bc44f821da1e2e6 /configure.in
parentc0d739039807abaa7985112370b4c5f4e85e02d7 (diff)
- Added --with-default-path to specify custom path for server
- Removed #ifdef trickery from acconfig.h into defines.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6cfacd2d..17b392d8 100644
--- a/configure.in
+++ b/configure.in
@@ -267,7 +267,7 @@ AC_EGREP_HEADER(syslen, utmpx.h,
dnl Look for lastlog location
AC_ARG_WITH(lastlog,
- [ --with-lastlog Location of lastlog file],
+ [ --with-lastlog=FILE Location of lastlog file],
[
if test "x$withval" = "xno" ; then
AC_DEFINE(DISABLE_LASTLOG)
@@ -396,6 +396,15 @@ AC_ARG_WITH(ipaddr-display,
]
)
+AC_ARG_WITH(path,
+ [ --with-default-path=PATH Specify default \$PATH environment for server],
+ [
+ if test "x$withval" != "xno" ; then
+ AC_DEFINE_UNQUOTED(USER_PATH, $withval")
+ fi
+ ]
+)
+
dnl Check for mail directory (last resort if we cannot get it from headers)
if test ! -z "$MAIL" ; then
maildir=`dirname $MAIL`