summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-02-07 13:20:26 +1100
committerDamien Miller <djm@mindrot.org>2000-02-07 13:20:26 +1100
commit36143d785143daabda83962a0f34404a9abf0964 (patch)
tree7c25bfde7fae4a60484dde3782938f9155e83955 /configure.in
parent8b171bc4cd9367e9dc99e53ebabcb0d04f9ba7da (diff)
- Removed SOCKS code. Will support through a ProxyCommand.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in55
1 files changed, 2 insertions, 53 deletions
diff --git a/configure.in b/configure.in
index 1176bfc4..f2128d7f 100644
--- a/configure.in
+++ b/configure.in
@@ -524,59 +524,6 @@ if test ! -z "$nolastlog" ; then
AC_DEFINE(DISABLE_LASTLOG)
fi
-dnl Compile with dante SOCKS library
-AC_ARG_WITH(dante,
- [ --with-dante=DIR Use Dante SOCKS lib (default is system library path)],
- [
- SAVELIBS="$LIBS"
- SOCKSLIBS=""
- SOCKSLIBPATH=""
- if test "x$withval" != "xno" ; then
- if test -n $withval ; then
- LIBS="$LIBS -L$withval"
- SOCKSLIBPATH="-L$withval"
- fi
- AC_CHECK_LIB(socks, Rconnect, AC_DEFINE(HAVE_DANTE) SOCKSLIBS="$SOCKSLIBPATH -lsocks")
- fi
- LIBS="$SAVELIBS $SOCKSLIBS"
- ]
-)
-
-dnl Compile with SOCKS4 SOCKS library
-AC_ARG_WITH(socks4,
- [ --with-socks4=DIR Use Socks4 SOCKS lib (default is system library path)],
- [
- SAVELIBS="$LIBS"
- SOCKSLIBS=""
- SOCKSLIBPATH=""
- if test "x$withval" != "xno" ; then
- if test -n $withval ; then
- LIBS="$LIBS -L$withval"
- SOCKSLIBPATH="-L$withval"
- fi
- AC_CHECK_LIB(socks, Rconnect, AC_DEFINE(HAVE_SOCKS4) SOCKSLIBS="$SOCKSLIBPATH -lsocks")
- fi
- LIBS="$SAVELIBS $SOCKSLIBS"
- ]
-)
-
-dnl Compile with SOCKS5 SOCKS library
-AC_ARG_WITH(socks5,
- [ --with-socks5=DIR Use Socks5 SOCKS lib (default is system library path)],
- [
- SAVELIBS="$LIBS"
- SOCKSLIBS=""
- SOCKSLIBPATH=""
- if test "x$withval" != "xno" ; then
- if test -n $withval ; then
- LIBS="$LIBS -L$withval"
- SOCKSLIBPATH="-L$withval"
- fi
- AC_CHECK_LIB(socks5, SOCKSconnect, AC_DEFINE(HAVE_SOCKS5) SOCKSLIBS="$SOCKSLIBPATH -lsocks5")
- fi
- LIBS="$SAVELIBS $SOCKSLIBS"
- ]
-)
AC_ARG_WITH(catman,
[ --with-catman=man|cat Install preformatted manpages[no]],
[
@@ -769,3 +716,5 @@ if test ! -z "$MAIL" ; then
fi
AC_OUTPUT(Makefile)
+
+