summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-03-17 10:54:15 +1100
committerDamien Miller <djm@mindrot.org>2000-03-17 10:54:15 +1100
commit29ea30d95627517e45e886820e3ef32168bd8dd7 (patch)
treea18a0eb90f9b74dfb4e3b2eb9e54888893693f1b /configure.in
parent696be9031b42c341c45ec36e2cd10db7869fb93a (diff)
- Clarified --with-default-path option.
- Added -blibpath handling for AIX to work around stupid runtime linking. Problem elucidated by gshapiro@SENDMAIL.ORG by way of Jim Knoble <jmknoble@pobox.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 81265f1e..0eeda65e 100644
--- a/configure.in
+++ b/configure.in
@@ -29,6 +29,9 @@ case "$host" in
AFS_LIBS="-lld"
CFLAGS="$CFLAGS -I/usr/local/include"
LDFLAGS="$LDFLAGS -L/usr/local/lib"
+ if test "$LD" != "gcc" -a -z "$blibpath"; then
+ blibpath="/usr/lib:/lib:/usr/local/lib"
+ fi
AC_DEFINE(BROKEN_GETADDRINFO)
;;
*-*-hpux10*)
@@ -239,6 +242,9 @@ else
if test ! -z "$need_dash_r" ; then
LDFLAGS="$LDFLAGS -R$ssldir/lib -R$ssldir"
fi
+ if test ! -z "$blibpath" ; then
+ blibpath="$blibpath:$ssldir:$ssldir/lib"
+ fi
fi
if test -z "$WANTS_RSAREF" ; then
LIBS="$saved_LIBS -lcrypto"
@@ -646,6 +652,12 @@ AC_ARG_WITH(kerberos4,
if test "x$withval" != "$xyes" ; then
CFLAGS="$CFLAGS -I${withval}/include"
LDFLAGS="$LDFLAGS -L${withval}/lib"
+ if test ! -z "$need_dash_r" ; then
+ LDFLAGS="$LDFLAGS -R${withval}/lib"
+ fi
+ if test ! -z "$blibpath" ; then
+ blibpath="$blibpath:${withval}/lib"
+ fi
else
if test -d /usr/include/kerberosIV ; then
CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
@@ -826,4 +838,9 @@ AC_ARG_WITH(pid-dir,
AC_DEFINE_UNQUOTED(PIDDIR, "$piddir")
AC_SUBST(piddir)
+if test ! -z "$blibpath" ; then
+ LDFLAGS="$LDFLAGS -blibpath:$blibpath"
+ AC_MSG_WARN([Please check and edit -blibpath in LDFLAGS in Makefile])
+fi
+
AC_OUTPUT(Makefile)