summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-03-16 10:48:25 +1100
committerDamien Miller <djm@mindrot.org>2000-03-16 10:48:25 +1100
commit166bd448c92574b5fed88d24e9ca0af1481fe680 (patch)
tree937847826238c88a83ba698991bf75217433bd9b /configure.in
parent08c788a9b3cc9eb211c65c4b33868beb81a9cfd1 (diff)
- Propogate LD through to Makefile
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 27317bea..81265f1e 100644
--- a/configure.in
+++ b/configure.in
@@ -4,10 +4,6 @@ AC_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_CANONICAL_HOST
-# C Compiler features
-if test "$GCC" = "yes"; then CFLAGS="$CFLAGS -Wall"; fi
-AC_C_INLINE
-
# Checks for programs.
AC_PROG_CPP
AC_PROG_RANLIB
@@ -16,6 +12,17 @@ AC_CHECK_PROG(AR, ar, ar)
AC_PATH_PROG(PERL, perl)
AC_SUBST(PERL)
+if test -z "$LD" ; then
+ LD=$CC
+fi
+AC_SUBST(LD)
+
+# C Compiler features
+AC_C_INLINE
+if test "$GCC" = "yes"; then
+ CFLAGS="$CFLAGS -Wall"
+fi
+
# Check for some target-specific stuff
case "$host" in
*-*-aix*)