summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2006-09-03 22:44:49 +1000
committerDarren Tucker <dtucker@zip.com.au>2006-09-03 22:44:49 +1000
commited0b59218ef9bb41a25922885d3fae7e67b8ba04 (patch)
treee0f887b046a8ca04609ae104a43a30ad7f02c9dd /configure.ac
parent46aa3e0ce1d2f341bb3e4d46035faae3bb5ee69c (diff)
- (dtucker) [configure.ac openbsd-compat/openbsd-compat.h] Check for
declaration of writev(2) and declare it ourselves if necessary. Makes the atomiciov() calls build on really old systems. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c37d7f49..cdabbd8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.357 2006/09/01 10:29:11 dtucker Exp $
+# $Id: configure.ac,v 1.358 2006/09/03 12:44:49 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
-AC_REVISION($Revision: 1.357 $)
+AC_REVISION($Revision: 1.358 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -1328,6 +1328,12 @@ AC_CHECK_DECLS(O_NONBLOCK, , ,
#endif
])
+AC_CHECK_DECLS(writev, , , [
+#include <sys/types.h>
+#include <sys/uio.h>
+#include <unistd.h>
+ ])
+
AC_CHECK_FUNCS(setresuid, [
dnl Some platorms have setresuid that isn't implemented, test for this
AC_MSG_CHECKING(if setresuid seems to work)