summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2007-04-29 15:06:44 +1000
committerDarren Tucker <dtucker@zip.com.au>2007-04-29 15:06:44 +1000
commitdca0edff2fb312e05fd7f2d560fb80bc97a38350 (patch)
tree09e924dd1b7d19266473ecd2a188aee29e3e8a75 /configure.ac
parent391de5c0237a452d7653e88b54c825a5fb468e3a (diff)
- (dtucker) [configure.ac defines.h] Have configure check for offsetof
to prevent redefinition warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c113b2fa..dbe77cbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.378 2007/04/29 04:49:21 dtucker Exp $
+# $Id: configure.ac,v 1.379 2007/04/29 05:06:44 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
-AC_REVISION($Revision: 1.378 $)
+AC_REVISION($Revision: 1.379 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -1375,6 +1375,10 @@ AC_CHECK_DECLS(MAXSYMLINKS, , , [
#include <sys/param.h>
])
+AC_CHECK_DECLS(offsetof, , , [
+#include <stddef.h>
+ ])
+
AC_CHECK_FUNCS(setresuid, [
dnl Some platorms have setresuid that isn't implemented, test for this
AC_MSG_CHECKING(if setresuid seems to work)