summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2006-10-07 09:07:20 +1000
committerDarren Tucker <dtucker@zip.com.au>2006-10-07 09:07:20 +1000
commitadc947d5a532880e7a2ffd1828789ada8fea6931 (patch)
treed13e2b2161fbf073180ce517b8393cddd6416684 /configure.ac
parent09f1093a29e6dcbec76cfa1831d080ced2d4b627 (diff)
- (dtucker) [configure.ac] Set put -lselinux into $LIBS while testing for
SELinux functions so they're detected correctly. Patch from pebenito at gentoo.org.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ecfa50c4..c596a7bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.369 2006/10/03 16:34:35 tim Exp $
+# $Id: configure.ac,v 1.370 2006/10/06 23:07:21 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
-AC_REVISION($Revision: 1.369 $)
+AC_REVISION($Revision: 1.370 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -3145,7 +3145,10 @@ AC_ARG_WITH(selinux,
AC_MSG_ERROR(SELinux support requires selinux.h header))
AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ],
AC_MSG_ERROR(SELinux support requires libselinux library))
+ save_LIBS="$LIBS"
+ LIBS="$LIBS $LIBSELINUX"
AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
+ LIBS="$save_LIBS"
fi ]
)
AC_SUBST(LIBSELINUX)