summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2018-10-27 16:45:59 +1100
committerDarren Tucker <dtucker@dtucker.net>2018-10-27 16:45:59 +1100
commit262d81a259d4aa1507c709ec9d5caa21c7740722 (patch)
treec7b8258f4a5f2713d026d679a3f618677c9db7ff /configure.ac
parent406a24b25d6a2bdd70cacd16de7e899dcb2a8829 (diff)
Check for the existence of openssl version funcs.
Check for the existence of openssl version functions and use the ones detected instead of trying to guess based on the int32 version identifier. Fixes builds with LibreSSL.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a4109eff..10696513 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2585,6 +2585,9 @@ if test "x$openssl" = "xyes" ; then
]
)
+ # Determining OpenSSL library version is version dependent.
+ AC_CHECK_FUNCS([OpenSSL_version OpenSSL_version_num])
+
# Determine OpenSSL library version
AC_MSG_CHECKING([OpenSSL library version])
AC_RUN_IFELSE(
@@ -2601,10 +2604,14 @@ if test "x$openssl" = "xyes" ; then
fd = fopen(DATA,"w");
if(fd == NULL)
exit(1);
-#if OPENSSL_VERSION_NUMBER < 0x10100000L
-# define OpenSSL_version_num SSLeay
+#ifndef OPENSSL_VERSION
+# define OPENSSL_VERSION SSLEAY_VERSION
+#endif
+#ifndef HAVE_OPENSSL_VERSION
# define OpenSSL_version SSLeay_version
-# define OPENSSL_VERSION SSLEAY_VERSION
+#endif
+#ifndef HAVE_OPENSSL_VERSION_NUM
+# define OpenSSL_version_num SSLeay
#endif
if ((rc = fprintf(fd, "%08lx (%s)\n",
(unsigned long)OpenSSL_version_num(),
@@ -2650,8 +2657,8 @@ if test "x$openssl" = "xyes" ; then
#include <openssl/opensslv.h>
#include <openssl/crypto.h>
]], [[
-#if OPENSSL_VERSION_NUMBER < 0x10100000L
-# define OpenSSL_version_num SSLeay
+#ifndef HAVE_OPENSSL_VERSION_NUM
+# define OpenSSL_version_num SSLeay
#endif
exit(OpenSSL_version_num() == OPENSSL_VERSION_NUMBER ? 0 : 1);
]])],