summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2013-03-16 20:55:46 -0700
committerTim Rice <tim@multitalents.net>2013-03-16 20:55:46 -0700
commitaa86c3970f24fc22185a9561ae84eeae0c6d15cd (patch)
tree5442f1959d28524db6ee0820fe7e0252237c3575 /configure.ac
parent585284019020eccaf0ce744df198bd56b6aa109f (diff)
- (tim) [configure.ac] OpenServer 5 wants lastlog even though it has none
of the bits the configure test looks for.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 907192d6..5d835c93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.516 2013/03/14 23:34:25 djm Exp $
+# $Id: configure.ac,v 1.517 2013/03/17 03:55:47 tim Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
-AC_REVISION($Revision: 1.516 $)
+AC_REVISION($Revision: 1.517 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_LANG([C])
@@ -897,6 +897,7 @@ mips-sony-bsd|mips-sony-newsos4)
AC_CHECK_FUNCS([getluid setluid])
MANTYPE=man
TEST_SHELL=ksh
+ SKIP_DISABLE_LASTLOG_DEFINE=yes
;;
*-*-unicosmk*)
AC_DEFINE([NO_SSH_LASTLOG], [1],
@@ -4472,7 +4473,9 @@ if test ! -z "$blibpath" ; then
fi
AC_CHECK_MEMBER([struct lastlog.ll_line], [], [
+ if test x$SKIP_DISABLE_LASTLOG_DEFINE != "xyes" ; then
AC_DEFINE([DISABLE_LASTLOG])
+ fi
], [
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>