summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2005-08-26 13:15:19 -0700
committerTim Rice <tim@multitalents.net>2005-08-26 13:15:19 -0700
commit2291c00ab2aef934391c23227645121719df4c4b (patch)
treee54919cbc0f3992c2b6988d36898b40f838360ba /configure.ac
parent8cc2ad68cd886d5f55a40b46a8e4d60931217a33 (diff)
- (tim) [CREDITS LICENCE auth.c configure.ac defines.h includes.h session.c
openbsd-compat/Makefile.in openbsd-compat/openbsd-compat.h openbsd-compat/xcrypt.c] New files [openssh/openbsd-compat/port-uw.c openssh/openbsd-compat/port-uw.h] Support long passwords (> 8-char) on UnixWare 7 from Dhiraj Gulati and Ahsan Rashid. Cleanup and testing by tim@. Feedback and OK dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f1588c69..c9c8218d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.288 2005/08/24 00:11:26 tim Exp $
+# $Id: configure.ac,v 1.289 2005/08/26 20:15:20 tim Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -446,6 +446,8 @@ mips-sony-bsd|mips-sony-newsos4)
;;
# UnixWare 7.x, OpenUNIX 8
*-*-sysv5*)
+ check_for_libcrypt_later=1
+ AC_DEFINE(UNIXWARE_LONG_PASSWORDS, 1, [Support passwords > 8 chars])
AC_DEFINE(USE_PIPES)
AC_DEFINE(SETEUID_BREAKS_SETUID)
AC_DEFINE(BROKEN_SETREUID)
@@ -643,6 +645,7 @@ AC_CHECK_HEADERS( \
getopt.h \
glob.h \
ia.h \
+ iaf.h \
lastlog.h \
limits.h \
login.h \
@@ -1721,6 +1724,7 @@ if test "x$check_for_libcrypt_later" = "x1"; then
AC_CHECK_LIB(crypt, crypt, LIBS="$LIBS -lcrypt")
fi
+AC_CHECK_LIB(iaf, ia_openinfo)
### Configure cryptographic random number support