summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2015-02-21 15:10:33 +1100
committerDarren Tucker <dtucker@zip.com.au>2015-02-21 15:10:33 +1100
commite50e8c97a9cecae1f28febccaa6ca5ab3bc10f54 (patch)
treeef2e49e129797e656bb38807a9a03a40bef981d8 /configure.ac
parent18a208d6a460d707a45916db63a571e805f5db46 (diff)
Add null declaration of AI_NUMERICINFO.
Some platforms (older FreeBSD and DragonFly versions) do have getaddrinfo() but do not have AI_NUMERICINFO. so define it to zero in those cases.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cb66f54b..2ef9db6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2197,6 +2197,13 @@ if test "x$ac_cv_func_getaddrinfo" = "xyes" && \
)
fi
+if test "x$ac_cv_func_getaddrinfo" = "xyes"; then
+ AC_CHECK_DECLS(AI_NUMERICSERV, , ,
+ [#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netdb.h>])
+fi
+
if test "x$check_for_conflicting_getspnam" = "x1"; then
AC_MSG_CHECKING([for conflicting getspnam in shadow.h])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <shadow.h> ]],