summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2009-10-11 21:50:20 +1100
committerDarren Tucker <dtucker@zip.com.au>2009-10-11 21:50:20 +1100
commitc182d993762f86fbdf9e54dd5b0e3e3d229ebc13 (patch)
treec2d047591f1534a0184f0d578ff9f40172937a3c /configure.ac
parent538738d861cefb25d78615b1c299d7b618db870c (diff)
- (dtucker) [configure.ac sftp-client.c] Remove the gyrations required for
dirent d_type and DTTOIF as we've switched OpenBSD to the more portable lstat.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 80db43af..0447bd62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.429 2009/10/07 07:56:10 dtucker Exp $
+# $Id: configure.ac,v 1.430 2009/10/11 10:50:20 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
-AC_REVISION($Revision: 1.429 $)
+AC_REVISION($Revision: 1.430 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -1130,15 +1130,6 @@ int main(void){struct dirent d;exit(sizeof(d.d_name)<=sizeof(char));}
]
)
-AC_CHECK_DECL(DTTOIF,
- AC_DEFINE(DTTOIF_IN_FS_FFS_DIR_H, 1 , [DTTOIF macro in fs/ffs/dir.h]), ,
- [
-#include <sys/types.h>
-#include <fs/ffs/dir.h>
- ])
-
-AC_CHECK_MEMBERS([struct dirent.d_type],,, [#include <dirent.h>])
-
AC_MSG_CHECKING([for /proc/pid/fd directory])
if test -d "/proc/$$/fd" ; then
AC_DEFINE(HAVE_PROC_PID, 1, [Define if you have /proc/$pid/fd])