summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2003-05-15 10:53:49 +1000
committerDamien Miller <djm@mindrot.org>2003-05-15 10:53:49 +1000
commit7abe09bf86b0ce437dfbf5dd7ccafadd1f39289e (patch)
tree8b2d0ee59f1c796affbbe18a643f1ddd0d97f980 /configure.ac
parent54c459866e2da288a3895eecf097104ac6f9f4d0 (diff)
- (djm) Configure glue for DNS support (code doesn't work in portable yet)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 29 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7a24838f..000fb4bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.117 2003/05/10 09:28:02 djm Exp $
+# $Id: configure.ac,v 1.118 2003/05/15 00:53:49 djm Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -1804,7 +1804,6 @@ if test "x$ac_cv_libc_defines_sys_nerr" = "xyes" ; then
fi
SCARD_MSG="no"
-
# Check whether user wants sectok support
AC_ARG_WITH(sectok,
[ --with-sectok Enable smartcard support using libsectok],
@@ -1854,6 +1853,32 @@ if test x$opensc_config_prefix != x ; then
fi
fi
+# Check whether user wants DNS support
+DNS_MSG="no"
+AC_ARG_WITH(dns,
+ [ --with-dns Support for fetching keys from DNS (experimental)],
+ [
+ if test "x$withval" != "xno" ; then
+ AC_DEFINE(DNS)
+ DNS_MSG="yes"
+ fi
+ ]
+)
+
+LWRES_MSG=""
+AC_ARG_WITH(lwres,
+ [ --with-lwres Use lwres library/headers for DNS support],
+ [
+ if test "x$withval" != "xno" -a "x$DNS_MSG" = "xyes"; then
+ AC_DEFINE(LWRES)
+ LWRES_MSG="(using liblwres)"
+ AC_SEARCH_LIBS(lwres_herror, lwres)
+ fi
+ ]
+)
+
+
+
# Check whether user wants Kerberos 5 support
KRB5_MSG="no"
AC_ARG_WITH(kerberos5,
@@ -2578,7 +2603,8 @@ if test ! -z "$superuser_path" ; then
echo " sshd superuser user PATH: $J"
fi
echo " Manpage format: $MANTYPE"
-echo " PAM support: ${PAM_MSG}"
+echo " DNS support: $DNS_MSG $LWRES_MSG"
+echo " PAM support: $PAM_MSG"
echo " KerberosIV support: $KRB4_MSG"
echo " KerberosV support: $KRB5_MSG"
echo " Smartcard support: $SCARD_MSG"