summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2021-02-18 12:06:25 +1100
committerDamien Miller <djm@mindrot.org>2021-02-18 12:06:25 +1100
commit324449a68d510720d0e4dfcc8e9e5a702fe6a48f (patch)
treef60f6622e65c52dbd02ec916d2468e8effddc7e4 /configure.ac
parent845fe9811c047063d935eca89188ed55c993626b (diff)
support OpenSSL 3.x cipher IV API change
OpenSSL renamed the "get current CIPHER_CTX" IV operation in 3.x. This uses the new name if available. https://github.com/openssl/openssl/issues/13411 bz#3238 ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6b75cf97..fe225731 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2867,6 +2867,7 @@ if test "x$openssl" = "xyes" ; then
EVP_CIPHER_CTX_iv \
EVP_CIPHER_CTX_iv_noconst \
EVP_CIPHER_CTX_get_iv \
+ EVP_CIPHER_CTX_get_updated_iv \
EVP_CIPHER_CTX_set_iv \
RSA_get0_crt_params \
RSA_get0_factors \