summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2005-09-22 20:15:08 +1000
committerDarren Tucker <dtucker@zip.com.au>2005-09-22 20:15:08 +1000
commitc373a56343f0f70ef88db1848a3888e84b18bd33 (patch)
treeaf0dbed5ac79a99dd7ca1f63a8d4bdc6af727b30 /configure.ac
parent542f62b9d29f4e6f596261f00d2b953cfcb826a5 (diff)
- (dtucker) [configure.ac] Use -R linker flag for libedit too; patch from
skeleten at shillest.net.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 226730f3..ff1f87ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.294 2005/09/19 16:33:39 tim Exp $
+# $Id: configure.ac,v 1.295 2005/09/22 10:15:08 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -1093,8 +1093,12 @@ AC_ARG_WITH(libedit,
[ --with-libedit[[=PATH]] Enable libedit support for sftp],
[ if test "x$withval" != "xno" ; then
if test "x$withval" != "xyes"; then
- CPPFLAGS="$CPPFLAGS -I$withval/include"
- LDFLAGS="$LDFLAGS -L$withval/lib"
+ CPPFLAGS="$CPPFLAGS -I${withval}/include"
+ if test -n "${need_dash_r}"; then
+ LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
+ else
+ LDFLAGS="-L${withval}/lib ${LDFLAGS}"
+ fi
fi
AC_CHECK_LIB(edit, el_init,
[ AC_DEFINE(USE_LIBEDIT, 1, [Use libedit for sftp])