summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2019-11-01 18:26:07 +1100
committerDarren Tucker <dtucker@dtucker.net>2019-11-01 18:27:37 +1100
commit9cac151c2dc76b8e5b727b2fa216f572e372170f (patch)
treec2455b4d72f5d53a12d49bbab1c855885f750afe /configure.ac
parent0e3c5bc50907d2058407641b5a3581b7eda91b7e (diff)
Add flags needed to build and work on Ultrix.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dcb44915..4baaa62a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1201,8 +1201,24 @@ mips-sony-bsd|mips-sony-newsos4)
*-*-ultrix*)
AC_DEFINE([BROKEN_GETGROUPS], [1], [getgroups(0,NULL) will return -1])
- AC_DEFINE([NEED_SETPGRP])
+ AC_DEFINE([NEED_SETPGRP], [1], [Need setpgrp to for controlling tty])
AC_DEFINE([HAVE_SYS_SYSLOG_H], [1], [Force use of sys/syslog.h on Ultrix])
+ AC_DEFINE([DISABLE_UTMPX], [1], [Disable utmpx])
+ # DISABLE_FD_PASSING so that we call setpgrp as root, otherwise we
+ # don't get a controlling tty.
+ AC_DEFINE([DISABLE_FD_PASSING], [1], [Need to call setpgrp as root])
+ AC_DEFINE([realpath(x, y)], [(sftp_realpath((x),(y)))], [no realpath])
+ # On Ultrix netinet/ip.h is not protected against multiple includes,
+ # so we create our own wrapper and put it where the compiler will
+ # find it.
+ AC_MSG_WARN([creating compat wrapper for netinet/ip.h])
+ mkdir -p netinet
+ cat >netinet/ip.h <<EOD
+#ifndef _SSH_COMPAT_NETINET_IP_H
+#define _SSH_COMPAT_NETINET_IP_H
+#include "/usr/include/netinet/ip.h"
+#endif
+EOD
;;
*-*-lynxos)