summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2005-12-31 16:42:03 +1100
committerDamien Miller <djm@mindrot.org>2005-12-31 16:42:03 +1100
commit89e03bae5c7390019d66e1ff9a550b3b53150476 (patch)
treeec0860c930d0a066c9b48a86144879cd20113eb7 /configure.ac
parent598bbc2d8fd5025ad16f5d9ee71db4e0bf872cd2 (diff)
- (djm) [configure.ac] Disable Linux tun(4) compat code if linux/tun.h does
not exist
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 64046759..3126cfcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.317 2005/12/31 05:33:37 djm Exp $
+# $Id: configure.ac,v 1.318 2005/12/31 05:42:03 djm Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -326,9 +326,16 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
[Define if cmsg_type is not passed correctly])
;;
esac
- AC_DEFINE(SSH_TUN_LINUX, 1, [Open tunnel devices the Linux tun/tap way])
- AC_DEFINE(SSH_TUN_COMPAT_AF, 1, [Use tunnel device compatibility to OpenBSD])
- AC_DEFINE(SSH_TUN_PREPEND_AF, 1, [Prepend the address family to IP tunnel traffic])
+ # tun(4) forwarding compat code
+ AC_CHECK_HEADERS(linux/tun.h)
+ if test "x$ac_cv_header_linux_tun_h" = "xyes" ; then
+ AC_DEFINE(SSH_TUN_LINUX, 1,
+ [Open tunnel devices the Linux tun/tap way])
+ AC_DEFINE(SSH_TUN_COMPAT_AF, 1,
+ [Use tunnel device compatibility to OpenBSD])
+ AC_DEFINE(SSH_TUN_PREPEND_AF, 1,
+ [Prepend the address family to IP tunnel traffic])
+ fi
;;
mips-sony-bsd|mips-sony-newsos4)
AC_DEFINE(NEED_SETPRGP, 1, [Need setpgrp to acquire controlling tty])