summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2007-04-29 14:39:02 +1000
committerDarren Tucker <dtucker@zip.com.au>2007-04-29 14:39:02 +1000
commit6d862a50dbe6a473c2e204d85d3e66e6a0293614 (patch)
tree1463a5f23f29be1703690ff9c37b8120782d9071 /configure.ac
parent2ac529b5055ebccd5c2251e373940eee156dc967 (diff)
- (dtucker) [configure.ac defines.h] Have configure check for MAXSYMLINKS
so we don't get redefinition warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4d551b89..f2e88f1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.376 2007/04/29 03:58:07 dtucker Exp $
+# $Id: configure.ac,v 1.377 2007/04/29 04:39:03 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
-AC_REVISION($Revision: 1.376 $)
+AC_REVISION($Revision: 1.377 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -1364,6 +1364,10 @@ AC_CHECK_DECLS(writev, , , [
#include <unistd.h>
])
+AC_CHECK_DECLS(MAXSYMLINKS, , , [
+#include <sys/param.h>
+ ])
+
AC_CHECK_FUNCS(setresuid, [
dnl Some platorms have setresuid that isn't implemented, test for this
AC_MSG_CHECKING(if setresuid seems to work)