summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2005-02-09 22:12:30 +1100
committerDarren Tucker <dtucker@zip.com.au>2005-02-09 22:12:30 +1100
commitc7e38d59e906dcb8028deccac6793463c5ca8f5c (patch)
treee0021b515e1ccd9c8e2694e4aabf490e8dcc2a25 /configure.ac
parent92170a862634bf9ebe958cc75911658d18e30538 (diff)
- (dtucker) [configure.ac] Bug #854: prepend pwd to relative --with-ssl-dir
paths. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 86b26daf..3ccbbaf0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.237 2005/02/02 12:30:25 dtucker Exp $
+# $Id: configure.ac,v 1.238 2005/02/09 11:12:31 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -1226,6 +1226,10 @@ AC_ARG_WITH(ssl-dir,
[ --with-ssl-dir=PATH Specify path to OpenSSL installation ],
[
if test "x$withval" != "xno" ; then
+ case "$withval" in
+ # Relative paths
+ ./*|../*) withval="`pwd`/$withval"
+ esac
if test -d "$withval/lib"; then
if test -n "${need_dash_r}"; then
LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"