summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2002-01-14 19:01:03 +1100
committerDamien Miller <djm@mindrot.org>2002-01-14 19:01:03 +1100
commita234451a706f091e1f1f60203ade0dca3d7e99b6 (patch)
treed74fcefb464dbddccb45e22a8c2a815f26bcd378 /configure.ac
parent2f8f6e3b1c9b33dfb7caf9c67e041ba708d52536 (diff)
- (djm) Bug #50 - make autoconf entropy path checks more robust
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ec0274e7..0ed1dddd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-i# $Id: configure.ac,v 1.9 2002/01/05 23:24:28 stevesk Exp $
+i# $Id: configure.ac,v 1.10 2002/01/14 08:01:06 djm Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -1538,6 +1538,12 @@ AC_ARG_WITH(random,
[
if test "x$withval" != "xno" ; then
RANDOM_POOL="$withval";
+ if ! echo "$RANDOM_POOL" | grep -q '^/' ; then
+ AC_MSG_ERROR(You must specify an absolute path to the random device)
+ fi
+ if ! test -r "$RANDOM_POOL" ; then
+ AC_MSG_WARN(Random device is not readable)
+ fi
AC_DEFINE_UNQUOTED(RANDOM_POOL, "$RANDOM_POOL")
fi
],
@@ -1570,6 +1576,12 @@ AC_ARG_WITH(prngd-socket,
[
if test "x$withval" != "xno" ; then
PRNGD_SOCKET="$withval"
+ if echo "$PRNGD_SOCKET" | grep -q '^/' ; then
+ AC_MSG_ERROR(You must specify an absolute path to the entropy socket)
+ fi
+ if ! test -r "$PRNGD_SOCKET" ; then
+ AC_MSG_WARN(Entropy socket is not readable)
+ fi
AC_DEFINE_UNQUOTED(PRNGD_SOCKET, "$PRNGD_SOCKET")
fi
],