summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2018-10-23 17:10:41 +1100
committerDamien Miller <djm@mindrot.org>2018-10-23 17:10:41 +1100
commit859754bdeb41373d372e36b5dc89c547453addb3 (patch)
tree8255b9851d8fa6339f25e2044a1572624eebca8d /configure.ac
parentb9fea45a68946c8dfeace72ad1f6657c18f2a98a (diff)
remove remaining references to SSLeay
Prompted by Rosen Penev
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7379ab35..0d55bece 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2602,8 +2602,9 @@ if test "x$openssl" = "xyes" ; then
if(fd == NULL)
exit(1);
- if ((rc = fprintf(fd, "%08lx (%s)\n", (unsigned long)SSLeay(),
- SSLeay_version(SSLEAY_VERSION))) < 0)
+ if ((rc = fprintf(fd, "%08lx (%s)\n",
+ (unsigned long)OpenSSL_version_num(),
+ OpenSSL_version(OPENSSL_VERSION))) < 0)
exit(1);
exit(0);
@@ -2645,7 +2646,7 @@ if test "x$openssl" = "xyes" ; then
#include <openssl/opensslv.h>
#include <openssl/crypto.h>
]], [[
- exit(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1);
+ exit(OpenSSL_version_num() == OPENSSL_VERSION_NUMBER ? 0 : 1);
]])],
[
AC_MSG_RESULT([yes])
@@ -2673,7 +2674,7 @@ if test "x$openssl" = "xyes" ; then
AC_MSG_CHECKING([if programs using OpenSSL functions will link])
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([[ #include <openssl/evp.h> ]],
- [[ SSLeay_add_all_algorithms(); ]])],
+ [[ OpenSSL_add_all_algorithms(); ]])],
[
AC_MSG_RESULT([yes])
],
@@ -2684,7 +2685,7 @@ if test "x$openssl" = "xyes" ; then
AC_MSG_CHECKING([if programs using OpenSSL need -ldl])
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([[ #include <openssl/evp.h> ]],
- [[ SSLeay_add_all_algorithms(); ]])],
+ [[ OpenSSL_add_all_algorithms(); ]])],
[
AC_MSG_RESULT([yes])
],