summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2002-09-04 23:26:29 +1000
committerDamien Miller <djm@mindrot.org>2002-09-04 23:26:29 +1000
commitfc93d4bd31788a89341991dd500f40e6ed50cd4e (patch)
tree6d9effae1be512acbacd37119c5fa585dcb0394f /configure.ac
parent6b09792a55a787860e6a4f45f164234bcfc45bae (diff)
- (djm) Patch from itojun@ for Darwin OS: test getaddrinfo, reorder libcrypt
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 615fec2a..9d3593aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.85 2002/08/14 01:52:11 tim Exp $
+# $Id: configure.ac,v 1.86 2002/09/04 13:26:30 djm Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -98,7 +98,16 @@ case "$host" in
AC_DEFINE(IP_TOS_IS_BROKEN)
;;
*-*-darwin*)
- AC_DEFINE(BROKEN_GETADDRINFO)
+ AC_MSG_CHECKING(if we have working getaddrinfo)
+ AC_TRY_RUN([#include <mach-o/dyld.h>
+main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
+ exit(0);
+ else
+ exit(1);
+}], [AC_MSG_RESULT(working)],
+ [AC_MSG_RESULT(buggy)
+ AC_DEFINE(BROKEN_GETADDRINFO)],
+ [AC_MSG_RESULT(assume it is working)])
;;
*-*-hpux10.26)
if test -z "$GCC"; then
@@ -175,6 +184,7 @@ mips-sony-bsd|mips-sony-newsos4)
SONY=1
;;
*-*-netbsd*)
+ check_for_libcrypt_before=1
need_dash_r=1
;;
*-*-freebsd*)
@@ -718,6 +728,12 @@ if test "x$PAM_MSG" = "xyes" ; then
)
fi
+# Some systems want crypt() from libcrypt, *not* the version in OpenSSL,
+# because the system crypt() is more featureful.
+if test "x$check_for_libcrypt_before" = "x1"; then
+ AC_CHECK_LIB(crypt, crypt)
+fi
+
# Search for OpenSSL
saved_CPPFLAGS="$CPPFLAGS"
saved_LDFLAGS="$LDFLAGS"