summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin Steves <stevesk@pobox.com>2002-03-22 17:23:25 +0000
committerKevin Steves <stevesk@pobox.com>2002-03-22 17:23:25 +0000
commit939c9db9b1e71fed79edc6d77a2d89ca991f4b2e (patch)
tree6eb7d4da41d392404a75f9a18c22010abeb62029 /configure.ac
parent681d932634983e610421680af6f9759af0f47d06 (diff)
- (stevesk) HAVE_ACCRIGHTS_IN_MSGHDR configure support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 670764f5..4a61c82f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.26 2002/03/17 20:17:35 tim Exp $
+# $Id: configure.ac,v 1.27 2002/03/22 17:23:26 stevesk Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -1576,6 +1576,22 @@ if test "x$ac_cv_have_pw_change_in_struct_passwd" = "xyes" ; then
AC_DEFINE(HAVE_PW_CHANGE_IN_PASSWD)
fi
+AC_CACHE_CHECK([for msg_accrights field in struct msghdr],
+ ac_cv_have_accrights_in_msghdr, [
+ AC_TRY_COMPILE(
+ [
+#include <sys/socket.h>
+#include <sys/uio.h>
+ ],
+ [ struct msghdr m; m.msg_accrights = 0; ],
+ [ ac_cv_have_accrights_in_msghdr="yes" ],
+ [ ac_cv_have_accrights_in_msghdr="no" ]
+ )
+])
+if test "x$ac_cv_have_accrights_in_msghdr" = "xyes" ; then
+ AC_DEFINE(HAVE_ACCRIGHTS_IN_MSGHDR)
+fi
+
AC_CACHE_CHECK([if libc defines __progname], ac_cv_libc_defines___progname, [
AC_TRY_LINK([],
[ extern char *__progname; printf("%s", __progname); ],