summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2002-07-18 11:44:50 -0700
committerTim Rice <tim@multitalents.net>2002-07-18 11:44:50 -0700
commit907881ec8e6077a57c9b9f01c8a30db13cf52b69 (patch)
treef7ac1b464343aefb0a7844c999d38efcc02a0f16 /configure.ac
parent76645849d3c73b974a44393e9b0bbec46e0ab4c4 (diff)
[configure.ac] Bug 267 rework int64_t test.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 11 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index f94f6c84..281e2f63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.80 2002/07/18 02:20:08 tim Exp $
+# $Id: configure.ac,v 1.81 2002/07/18 18:44:50 tim Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -1038,7 +1038,16 @@ fi
AC_CACHE_CHECK([for int64_t type], ac_cv_have_int64_t, [
AC_TRY_COMPILE(
- [ #include <sys/types.h> ],
+ [
+#include <sys/types.h>
+#ifdef HAVE_STDINT_H
+# include <stdint.h>
+#endif
+#include <sys/socket.h>
+#ifdef HAVE_SYS_BITYPES_H
+# include <sys/bitypes.h>
+#endif
+ ],
[ int64_t a; a = 1;],
[ ac_cv_have_int64_t="yes" ],
[ ac_cv_have_int64_t="no" ]
@@ -1046,33 +1055,6 @@ AC_CACHE_CHECK([for int64_t type], ac_cv_have_int64_t, [
])
if test "x$ac_cv_have_int64_t" = "xyes" ; then
AC_DEFINE(HAVE_INT64_T)
- have_int64_t=1
-fi
-
-if test -z "$have_int64_t" ; then
- AC_MSG_CHECKING([for int64_t type in sys/socket.h])
- AC_TRY_COMPILE(
- [ #include <sys/socket.h> ],
- [ int64_t a; a = 1],
- [
- AC_DEFINE(HAVE_INT64_T)
- AC_MSG_RESULT(yes)
- ],
- [ AC_MSG_RESULT(no) ]
- )
-fi
-
-if test -z "$have_int64_t" ; then
- AC_MSG_CHECKING([for int64_t type in sys/bitypes.h])
- AC_TRY_COMPILE(
- [ #include <sys/bitypes.h> ],
- [ int64_t a; a = 1],
- [
- AC_DEFINE(HAVE_INT64_T)
- AC_MSG_RESULT(yes)
- ],
- [ AC_MSG_RESULT(no) ]
- )
fi
AC_CACHE_CHECK([for u_intXX_t types], ac_cv_have_u_intxx_t, [